summaryrefslogtreecommitdiff
path: root/_posts/2025-11-11-thoughts-on-georgia-psc.md
diff options
context:
space:
mode:
Diffstat (limited to '_posts/2025-11-11-thoughts-on-georgia-psc.md')
-rw-r--r--_posts/2025-11-11-thoughts-on-georgia-psc.md19
1 files changed, 19 insertions, 0 deletions
diff --git a/_posts/2025-11-11-thoughts-on-georgia-psc.md b/_posts/2025-11-11-thoughts-on-georgia-psc.md
new file mode 100644
index 0000000..8a9203c
--- /dev/null
+++ b/_posts/2025-11-11-thoughts-on-georgia-psc.md
@@ -0,0 +1,19 @@
+---
+layout: post
+title: "cgit"
+date: 2025-11-28
+permalink: "/blog/cgit"
+author: Benjamin Sanders
+catagories: cgit
+---
+Since I've moved my website(s) over to a dedicated server I started using I've been meaning to configure my own host for git repos. I ran
+into some trouble getting it to work properly but thanks to [Luke Smith's](https://lukesmith.xyz) [landchad.net](https://landchad.net) somebody had written an article how to get a basic one
+working.
+
+Turns out the main thing I was missing was this line from my nginx site config file `try_files $uri @cgit ;`. The error that fixed was a 403 Forbidden error I kept getting when attempting to visit [git.sanders.life](https://git.sanders.life/).
+
+I did use the article to make sure HTTPS cloning would work too though and cloned a couple repos I'm interested in having a mirror.
+
+Now, though, I can freely push my repos to my own server with a read-only frontend to it for other netizens!
+
+Anyway, thanks for reading this little update to my site and services. \ No newline at end of file