From cda4c38d2b79e0b6634412341dd3ba800dd03ed7 Mon Sep 17 00:00:00 2001 From: Benjamin Sanders Date: Fri, 18 Sep 2026 15:29:48 -0400 Subject: removed a random raft directory and changed background of site to #ccc and kept header background 0f1700 --- rafts/blog/cgit.html | 70 ---------------------------------------------------- 1 file changed, 70 deletions(-) delete mode 100644 rafts/blog/cgit.html (limited to 'rafts/blog/cgit.html') diff --git a/rafts/blog/cgit.html b/rafts/blog/cgit.html deleted file mode 100644 index a4ba175..0000000 --- a/rafts/blog/cgit.html +++ /dev/null @@ -1,70 +0,0 @@ - - - - - - Ben Sanders Online Space - - - - - - -
-
-
- -
-
-
-
-

cgit

- Benjamin Sanders | 28 November 2025 | cgit -

Since I’ve moved my website(s) over to a dedicated server I started using I’ve been meaning to configure my own host for git repos. I ran -into some trouble getting it to work properly but thanks to Luke Smith’s landchad.net somebody had written an article how to get a basic one -working.

- -

Turns out the main thing I was missing was this line from my nginx site config file try_files $uri @cgit ;. The error that fixed was a 403 Forbidden error I kept getting when attempting to visit git.sanders.life.

- -

I did use the article to make sure HTTPS cloning would work too though and cloned a couple repos I’m interested in having a mirror.

- -

Now, though, I can freely push my repos to my own server with a read-only frontend to it for other netizens!

- -

Anyway, thanks for reading this little update to my site and services.

- -
-
-
- - - \ No newline at end of file -- cgit v1.2.3